facebooktwittermenuarrow-up

GemBox Support Forum

Fonts don't work in IIS app

I have simple GemBox document convert routine (basically just loads a Word document and saves it as PDF). This works when I run it on my desktop system but when I run it as an application under IIS (Windows Server 2012R2) the fonts in the document are not coming through (for example a Lucida Calligraphy is coming through in a standard sans-serif font). The Lucida font is installed on the Windows Server but GemBox Document doesn’t seem to be able to use it. I have tried making it a private font (as per the example) by copying that font file to the application directory and setting the font directory to “.” but that doesn’t seem to be working either.

I’m probably doing something stupid but I can’t figure out what it is.

I figured it out. Sorry for the post

Hi Malcolm,

I’m glad you were able to solve your issue.

Perhaps you could write a bit on how you resolved it?
I believe others may find it useful if they encounter a similar issue.

Regards,
Mario